error: trying to remove "yum", which is protected



Tags : yum error

Trying to update one of the my VPS today with sudo yum update command and encounter this funky error message :

error: trying to remove "yum", which is protected

From the output :

 --> Finished Dependency Resolution
 Error: Package: coreutils-libs-8.4-31.el6_5.2.x86_64 (@updates)
 Requires: coreutils = 8.4-31.el6_5.2
 Removing: coreutils-8.4-31.el6_5.2.x86_64 (@updates)
 coreutils = 8.4-31.el6_5.2
 Updated By: coreutils-8.4-37.el6.x86_64 (base)
 coreutils = 8.4-37.el6
  You could try using --skip-broken to work around the problem
 ** Found 31 pre-existing rpmdb problem(s), 'yum check' output follows:

and issuing the sudo yum --skip-broken command will work but give this hint for what is causing the funky error :

error: Failed dependencies:

coreutils-libs = 8.4-31.el65.2 is needed by (installed) coreutils-8.4-31.el65.2.x86_64

seems like the package coreutils-8.4-31.el6_5.2.x86_64 is causing the problem with dependencies issue

SOLUTION :

To fix this funky error, use the rpm- e --justdb <package name> command and in my own example here, I'll just issue

> sudo rpm -e --justdb coreutils-libs-8.4-37.el6.x86_64

and than

> sudo yum update

bingo! all packages updated.



Tags : yum error

By Adam Ng

IF you gain some knowledge or the information here solved your programming problem. Please consider donating to the less fortunate or some charities that you like. Apart from donation, planting trees, volunteering or reducing your carbon footprint will be great too.


Advertisement